Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#86 closed defect (fixed)

filo sata boot delay patch

Reported by: ward Owned by: somebody
Priority: major Milestone:
Component: coreboot Keywords:
Cc: Dependencies:
Patch Status: patch has been committed


I've been using the attached patch to filo on machines that need to boot from SATA disks. It's only necessary on cold boot, as the problem is the physical spin-up of the drives.

The patch is very crude, and there have been reports that a shorter delay is sufficient. I have not had time to test a shorter delay, and I suspect that the length of the delay might depend somewhat on the drives used.

Ideally there would be a way for FILO to see if the boot was cold or warm so that it could apply the delay in the cold-boot case only. Also, this delay should be configurable in FILO's Config file.

Attachments (1)

filo_sata_delay.patch (258 bytes) - added by ward 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by ward

comment:1 Changed 8 years ago by ward

A further update. Five seconds turns out not to be enough for the new 1TB hitachi drives... I hope to be able to test a longer delay, and will report back.

comment:2 Changed 8 years ago by uwe

  • version v2 deleted

As the delay will be different for different systems and hard drives, I think this should be a FILO config option (and likely also a config option in lbgrub2, I guess).

comment:3 Changed 8 years ago by uwe

  • Patch Status changed from patch needs work to patch has been committed
  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

as closed The owner will remain somebody.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.