Unify SuperIO code?
|Reported by:||stepan||Owned by:||uwe|
|Patch Status:||there is no patch|
One thing I've been noticing in the current superio implementations: A lot of differences come from having the part names used in variable and macro names.
#define FDC37M60X_CONFIG_REG_CC 0x02
Maybe we should change that to some unique names
#define SUPERIO_CONFIG_REG_CC 0x02
- Those names are usually file local only, so name clashes wont be a problem
- They are the same for most (all?) SuperIOs?
Doing so (maybe with function names as well?) would unify the superio interface, or at least make diffing the code of different devices a bit easier..