Modify

Opened 5 years ago

Closed 5 years ago

#151 closed defect (duplicate)

v3 Geode cs5536 UART2 wrongly configured

Reported by: edwin_beasant@… Owned by: somebody
Priority: major Milestone: Going mainstream
Component: coreboot Keywords: serial com2 geode cs5536
Cc: edwin_beasant@… Dependencies:
Patch Status: patch needs review

Description

The UART2 on the AMD cs5536 is incorrectly configured in two places in v3 code and also in v2. GPIO lines 4 and 3 are swapped and also incorrectly put in IR mode receive (compound fault). This patch corrects the v3 late configuration and the v3 and v2 early (stage1/cache as ram) mis-configuration of UART2 to addres 0x3f8 not the standard 0x2f8 for COM2.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by stepan

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #152

Add Comment

Modify Ticket

Action
as closed The owner will remain somebody.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.